LwCad for LightWave
BOOLEAN subtract not working on simple objects?

So i have a box, trying to have a cylinder subtract a hole into . Doesn't work. See attached. Trying it with various objects , using version 2015.3...
LWCAD 5.51
This used to work fine. Now nothing..
Tried reset and reinstall..Nothing.
Any suggestions?

Gary5b381ee18f665

So i have a box, trying to have a cylinder subtract a hole into . Doesn't work. See attached. Trying it with various objects , using version 2015.3... LWCAD 5.51 This used to work fine. Now nothing.. Tried reset and reinstall..Nothing. Any suggestions? Gary![5b381ee18f665](serve/attachment&path=5b381ee18f665)
edited Jul 1 at 1:23 am

Boolean only works with polygons at this moment.
You must convert object to polygons if you want to perform a Boolean operation.

Boolean only works with polygons at this moment. You must convert object to polygons if you want to perform a Boolean operation.

Viktor Veličko, WTools3D founder

I found the problem, when using a cylinder to cut a hole in a box..the cylinder was at segment level 22. I had to lower it to 16 for it to work. Is this still a bug, why would the segment amount stop this working?

Gary

I found the problem, when using a cylinder to cut a hole in a box..the cylinder was at segment level 22. I had to lower it to 16 for it to work. Is this still a bug, why would the segment amount stop this working? Gary

It is interesting nobody reported this until now.
It will be be fixed as soon as next beta phase starts.

Thank you for reporting this!

It is interesting nobody reported this until now. It will be be fixed as soon as next beta phase starts. Thank you for reporting this!

Viktor Veličko, WTools3D founder

Hi Gary

I think the problem is with the "reduce" option. I'm using 2015.3 and LWCAD 5.51 as well and after unchecking it in the numeric panel I have no problem cutting a hole in the box using both real time boolean subtracting and the Bool tool even using a higher segment count.

5b494420e0d9a

Edit: It could be that having the reduce on you are telling LWCAD to remove the polys resulting from the boolean operation even as they are being created. So it may or may not be bug.

Hi Gary I think the problem is with the "reduce" option. I'm using 2015.3 and LWCAD 5.51 as well and after unchecking it in the numeric panel I have no problem cutting a hole in the box using both real time boolean subtracting and the Bool tool even using a higher segment count. ![5b494420e0d9a](serve/attachment&path=5b494420e0d9a) Edit: It could be that having the reduce on you are telling LWCAD to remove the polys resulting from the boolean operation even as they are being created. So it may or may not be bug.
edited Jul 14 at 1:56 am
82
6
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft