Codoforum Related Descussions
On my form using CODOLOGIC forum.

The latest OS X installer doesn't seem to work - I just a black panel with no options. Anyone else using this on C4D?

The latest OS X installer doesn't seem to work - I just a black panel with no options. Anyone else using this on C4D?

We are solving this issue with Apple right now.
It is problem with a new Gate Keeper in OSX Sierra.
I hope we will resolve this until next beta.

At this moment you need to manually allow installation of third party applications without signature.
It is the only way how to install latest LWCAD LITE 5.2028 on OSX Sierra.

Following link should help:
http://osxdaily.com/2016/09/27/allow-apps-from-anywhere-macos-gatekeeper/

We are solving this issue with Apple right now. It is problem with a new Gate Keeper in OSX Sierra. I hope we will resolve this until next beta. At this moment you need to manually allow installation of third party applications without signature. It is the only way how to install latest LWCAD LITE 5.2028 on OSX Sierra. Following link should help: http://osxdaily.com/2016/09/27/allow-apps-from-anywhere-macos-gatekeeper/

Viktor Veličko, WTools3D founder

edited Apr 25 at 7:19 pm

Installer problem on OSX has been solved!
New LWCAD LITE beta 5.2030 is uploaded.

If anybody will have a problem even with this latest version, please let us know back.
Thanks!

Installer problem on OSX has been solved! New LWCAD LITE beta 5.2030 is uploaded. If anybody will have a problem even with this latest version, please let us know back. Thanks!

Viktor Veličko, WTools3D founder


I tried first with Gatekeeper set normally, no luck. Even after setting Gatekeeper to "Anywhere", I'm still not being presented with any options in the "Quick install settings" window in the OSX Installer. This is on 5.2036, 10.12.6, C4D R18 present in "/Applications/MAXON/Cinema_4D_R18/". I've also tried removing the underbars ( ".../Cinema 4D R18/" ) to no avail.

Any suggestions?

I tried first with Gatekeeper set normally, no luck. Even after setting Gatekeeper to "Anywhere", I'm still not being presented with any options in the "Quick install settings" window in the OSX Installer. This is on 5.2036, 10.12.6, C4D R18 present in "/Applications/MAXON/Cinema_4D_R18/". I've also tried removing the underbars ( ".../Cinema 4D R18/" ) to no avail. Any suggestions?
edited Jul 30 at 1:20 am

Hello, have you changed default installation folder name when you installed Cinema?

LWCAD installer needs to find installation path:
"[home]/Library/Preferences/MAXON/Cinema 4D R18_[something]"

Check that folder, it is probably named "Cinema_4D_R18_[something]" and those first two underscores may cause the problem. Rename it to "Cinema 4D R18_[something]" and install LWCAD again. Don't forget to rename it back after the procedure because Cinema will probably not find it.

Please note that "Library" folder is hidden by default ("Shift+CMD+." unhides it in finder).

Let me know if that helped. Thank you.

PS: I try to figure out something to prevent these problems in the future.

Hello, have you changed default installation folder name when you installed Cinema? LWCAD installer needs to find installation path: "[home]/Library/Preferences/MAXON/Cinema 4D R18_[something]" Check that folder, it is probably named "Cinema_4D_R18_[something]" and those first two underscores may cause the problem. Rename it to "Cinema 4D R18_[something]" and install LWCAD again. Don't forget to rename it back after the procedure because Cinema will probably not find it. Please note that "Library" folder is hidden by default ("Shift+CMD+." unhides it in finder). Let me know if that helped. Thank you. PS: I try to figure out something to prevent these problems in the future.

Miroslav Kovac, WTools3D developer

edited Jul 31 at 1:00 pm

Once I removed the underscores from my C4D prefs folder, the installer was able to locate it and install properly. Thanks for that!

Long-term, I'd strongly suggest finding a way to adapt to such changes, because there are good reasons* not to leave spaces in the C4D install dir name, and that causes the prefs dir name to change as well.

In any case, I was able to install and run the plugin fine! I'm really liking how the LWCAD functionality was integrated into C4D. I find the LWCAD UX on C4D even superior to the LWCAD LW UX in many cases.

*: Certain plugin-associated utilities, etc. historically have problems with spaces in the main C4D directory name, as can utility shell scripts, etc.

Once I removed the underscores from my C4D prefs folder, the installer was able to locate it and install properly. Thanks for that! Long-term, I'd strongly suggest finding a way to adapt to such changes, because there are good reasons* not to leave spaces in the C4D install dir name, and that causes the prefs dir name to change as well. In any case, I was able to install and run the plugin fine! I'm really liking how the LWCAD functionality was integrated into C4D. I find the LWCAD UX on C4D even superior to the LWCAD LW UX in many cases. _*: Certain plugin-associated utilities, etc. historically have problems with spaces in the main C4D directory name, as can utility shell scripts, etc. _

105
5
4
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft